Activating License Keys And Access To Licensing Server From CDP Server (Ports And Firewalls)
Symptom
You cannot activate your license key. Your trial or heartbeat license key stops working because it has too many failed attempts contacting the licensing server.
Cause
The CDP Server connects to hostactivation.r1soft.com over the Internet on TCP port 443 and uses XML-RPC over HTTPS to activate license keys and do periodic checks for trial and heartbeat keys. A firewall or host based firewall (e.g. iptables) can block ports and keep the CDP Server from connecting to the licensing server. Or if your CDP Server does not have Internet access it can not connect to the licensing server.
Shrink Wrap (standard) license keys: Must connect to the licensing server once during registration to activate the key. After activation, there is no need to connect to the licensing server unless you upgrade your product with an add-on module or buy more Agents for that CDP Server key.
Trial Keys or Keys on Monthly Payment Plans: Must always have access to the licensing server. If the CDP server fails to connect to the licensing server after approximately one day of failed connects, the CDP Server will no longer function.
Resolution
Does your CDP Server have Internet access? If the answer is no and you have purchased regular (shrink wrap) license keys, you will need to temporarily connect the CDP Server to the Internet to activate the keys or upgrade your license with more Agents or add-ons. You will need Internet access to use a CDP Server trial key or a key issued on a monthly payment plan (must heartbeat top licensing server).
If your CDP Server has internet access ,check and make sure you can ping activation.r1soft.com from your CDP Server. If you can not ping activation.r1soft.com, check your network connection or settings.
If you can ping activation.r1soft.com from your CDP Server and still have problems activating license keys, you may have a firewall blocking access to activation.r1soft.com To check for this, try to telnet from your CDP Server to activation.r1soft.com port 443. Do you get a connection? If not, please adjust your firewall.
Firewall Allow Rules for the Licensing Server:
Input:
Output
Related Articles
| Page: How Do I Get a Logon For Software Downloads (Archived Knowledge Base 2.0) Labels: login, download, trial |
| Page: Do You Offer Trial License Keys? (Archived Knowledge Base 2.0) Labels: license, trial |
| Page: Activating License Keys And Access To Licensing Server From CDP Server (Ports And Firewalls) (Archived Knowledge Base 2.0) Labels: license, trial |